RSS

Update metasploit on backtrack

May 04

To  update the existing metasploit, in the backtrack terminal type
> msfupdate           (or)
>svn update /petnest/exploits/framework3 (or)

>sudo bash
>cd /opt/framework3/msf3/
>svn update
To remove metasploit from backtrack,
> apt-get purge framework3

To install the updated version,
> apt-get update && apt-get install framework3
If you notice the following error during up-gradation,  use the steps mentioned below.

“svn: /opt/framework/common/lib/libssl.so.0.9.8: no version information available (required by /opt/framework/common/lib/libserf-0.so.0)
svn: /opt/framework/common/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework/common/lib/libserf-0.so.0)”

> cd /opt/framework/common/lib
> mv libcrypto.so.0.9.8 libcrypto.so.0.9.8-b
> mv libssl.so.0.9.8 libssl.so.0.9.8-backup
> ln -s /usr/lib/libcrypto.so.0.9.8
> ln -s /usr/lib/libssl.so.0.9.8
> msfupdate

[Update – August 31, 2012]

Backtrack 5r1,
To uninstall existing  metasploit –
> cd /opt/framework/
> ./uninstall

To install the latest version of metasploit –
> apt-get update
> apt-get install metasploit

 

Posted by on May 4, 2011 in Metasploit

2 Comments

Tags: ,

2 responses to “Update metasploit on backtrack

  1. Holmns

    February 3, 2013 at 12:04 pm

    Thank you.

     
  2. ali

    April 17, 2013 at 7:52 am

    tnxxxxxxxxxxxxxxxxxxxxxxxxxx

     

Leave a Reply

Your email address will not be published. Required fields are marked *